Gerenciando switch’s 3com e HP via Linha de comando

Console switch HP

Descrevendo comandos básicos de switches com Sistem Operacional Comware.

Publicidade

Após logar com admin via ssh necessário entrar no modo de gerenciamentos do switch

_cmdline-mode on
Senha: 512900 ou Jinhua1920unauthorized  para sw hp 1920

Você entrará no modo User View. Para mode de configuração digite o seguinte comando:

system-view

Para sair de qualquer contexto use “quit” Para desfazer o comando utilize undo seguido do comando (Mesmo que “no” em outros switchs) Aqui não existe o comando show e sim o comando display

VLANS

Criar uma vlan ou entrar no contexto de uma vlan

vlan 15

Nomear vlan

vlan 11
 description nti
 name nti

Colocar a vlan em uma porta

port GigabitEthernet 1/0/21

Ver configuração de uma vlan, em qual porta está

display vlan 15

INTERFACES

Entrar no contexte de uma interface

interface GigabitEthernet 1/0/44

Configurar range de porta de uma vez (Não suportado em alguns hp)

interface range GigabitEthernet 1/0/1 to GigabitEthernet 1/0/10

Exibir configurações da interface

display interface GigabitEthernet 1/0/44

Colocar porta untag em uma vlan Primeira acessa a interface no exemplo é a 1/0/4

interface GigabitEthernet 1/0/4

Podemos mudar o tipo da interface (access, trunk , hybrid)

port link-type <access|trunk|hybrid>

Colocando porta em uma vlan untag

port access vlan 15

Desativar a porta

shutdown

Ativar a porta

undo shutdown

descrição da porta

description pcguilherme

Colocar uma porta como trunk

port link-type trunk

Acrescentar/retirar uma vlan à porta trunk

port trunk permit vlan 22	
undo port trunk permit vlan 22

Portas Hybridas (Entre no contexto da porta a ser configurada)

port link-type hybrid
interface GigabitEthernet 1/0/4
port hybrid vlan 11 tagged
port hybrid vlan 62 untagged

Retirar uma vlan da porta trunk

undo port hybrid vlan 11

Configuração Básica

Considerando um switch em configuração de fábrica:

  • Acessar o System- View
  • Criar a Vlan 56
  • Criar a Vlan-Interface 56
  • Desativar a Vlan 1
  • Incluir interface na Vlan 56 (tag)
  • Definir rota padrão

Os comandos relacionados são: vlan 56
[Vlan56] description Infra
[Vlan56] name Infra
[Vlan56] quit
interface Vlan-interface 56
[Vlan-interface56] ip address 10.200.56.X 255.255.254.0
[Vlan-interface56] quit
interface Vlan-interface 1
[Vlan-interface1] shutdown
[Vlan-interface1] quit
interface GigabitEthernet 1/0/24
[GigabitEthernet1/0/24] port link-type hybrid
[GigabitEthernet1/0/24] port hiybrid pvid vlan 56
[GigabitEthernet1/0/24] port hiybrid vlan 56 tagged
[GigabitEthernet1/0/24] quit
ip route-static 0.0.0.0 0 Vlan-interface 56 10.200.56.1 permanent
save

Outras funções

Exibir MAC e respectivas portas. (Portas troncos terão mais MAC’s e porta access apenas um MAC)

display mac-address

Colocar um ip em uma vlan especifica (Útil para utilizar a função layes 3 do sw)

interface Vlan-interface 11
ip address 143.106.49.110 26

Trocando a senha e permitindo ssh do usuário admin

local-user admin
password simple <senha>
service-type ssh

Habilitando o serviço ssh

ssh server enable

Configuração de Informações

Mudar o campo contato

snmp-agent sys-info contact 02/37710

Mudar o campo Localização

snmp-agent sys-info location fcm11-2-psq

Mudar o campo Sysname

sysname nomedoswitch

Configurando DNS e Hora(NTP)

Configuração de dns:

dns domain fcm.unicamp.br
dns server 143.106.46.46
dns resolve

Configurando servidor de horas

clock timezone Brasilia minus 03:00:00
ntp-service unicast-server ntp.fcm.unicamp.br